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1.1. Introduction 

MaZda is a computer program for calculation of texture parameters (features) in digitized images. It has been under 
development since 1998, to satisfy the needs of the participants of COST B11 European project "Quantitative Analysis of 
Magnetic Resonance Image Texture" and the subsequent COST B21 "Physiological modelling of magnetic resonance 

image formation". The program code has been written in C++ and compiled for PC computers that use MS Windows® XP 
operating system.  

MaZda was originally developed in 1996 at the Institute of Electronics, Technical University of Lodz (TUL), Poland, by 
Michal Strzelecki and Piotr Szczypinski, for texture analysis of mammograms. The statistical parameters computed by the 
early version of the program were derived from the co-occurrence matrix. Consequently, the name of the program is an 

acronym derived from ‘Macierz Zdarzen’ that is Polish counterpart of the English term ‘co-occurrence matrix’. Thus 
MaZda has no connotation of the famous Japanese car maker.  

MaZda User's Manual 

1.2. Functionality 

A flowchart illustrating typical steps in image texture analysis is shown in Fig. 1.2.1. Image acquisition is the first step. 
Although in the case of images considered in COST B11 action, this step is performed by means of a magnetic resonance 
scanner, the following analysis steps can be carried out on images of different origins, e.g. visual ones taken by a digital 
camera. 

The next two steps cover selection of a region of interest (ROI) and computation of texture parameters within the ROI. 
MaZda provides tools for performing these two steps. Lists of parameters computed for each ROI are displayed in a 
report window (Section 1.4). 

 



 

Fig. 1.2.1 Main steps in texture analysis 

It can not be said, in advance, which parameters computed for a given texture are best to distinguish one texture from 
another. Moreover, some of them are highly correlated to each other and thus they do not carry any new information 
about the texture at hand. Thus there is a need for parameter selection and reduction. Several techniques of feature 
selection implemented in MaZda are described in more detail in Section 3.2. 

Yet another program module was developed, for selected texture parameters preprocessing, exploratory analysis and 
texture data classification. This is called B11; it is called from within MaZda, or can be run on its own. Using the 
numerical routines available in this program, one is able to perform principal component analysis (PCA), linear 

discriminant analysis (LDA), nonlinear discriminant analysis (NDA) and unsupervised data clustering in the feature vector 
space. These data preprocessing methods are described in Section 4. The raw or preprocessed parameter vectors can be 
classified with B11, by means of a k-NN classifier or an artificial neural network (Section 4.5).  
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1.3. Main window 

The main window of MaZda, as it looks like after loading an image into its working area, is shown in Fig. 1.3.1. Besides 
the image panel, this window contains 8 elements - toolbars for image manipulation and/or processing (Fig. 1.3.2a -
1.3.2h). 



 

Fig 1.3.1 The main window of MaZda with an example MR image loaded 

 

Fig 1.3.2 Elements of MaZda main window: a) window title bar, b) menu bar, c) image panel, d) load file 
button, e) copy and move buttons, f) graphics toolbar for ROI edition, g) morphological tools for ROI 
edition, h) drawing mode selection buttons, i) ROI color selector, j) ROI on/off switches, k) zoom in/out 
buttons, l) sliders for adjustment of grey-scale palette, m) image view mode selector, n) status bar.  



An image displayed in the image panel consists of two main layers. One of them is the original image to be analyzed, as 

e.g. the image presented in Fig. 1.3.1. On top of this layer, the region of interest (ROI) image can be visualized, as e.g. 
shown in Fig. 1.3.3. To see the ROI image only, one has to click on the lowest radio button in the layer selector (Fig. 
1.3.4). More information about the display layers available, and how to switch them on and off, can be found in Section 
2.3. To add ROI to an image, one has to either load it from a file by means of File=>Load ROI menu options, or paint it 
using the graphics tool bar and ROI color selector. 

 

Fig 1.3.3 Region of interest (ROI) image, superimposed on the analysed image 

 

Fig 1.3.4 ROI image layer displayed using layer selector 

By setting the position of two sliders on the right-hand side of the window, one can adjust the boundaries of a conceptual 
window, on the brightness scale, through which the image is observed. Then, what is seen through this window is 



stretched out to the full brightness scale, available in the computer system. In this way, the contrast of the image can be 

enhanced (for visualization only, not for analysis!), as demonstrated in Fig. 1.3.5. 

 

Fig 1.3.5 The effect of sliders' position on image contrast 

By choosing the middle button of the image layer selector, one can change the function of the image display in yet 
another mode. In this mode, the sliders' positions define two thresholds on the brightness scale, respectively of low and 
high value. The image is converted into its 3-brightness-value representation, using black, grey and white colors. If the 
actual image brightness is lower than the lower threshold, black color is used. The original pixels whiter than the higher 
threshold are displayed as white points. Those pixels, whose brightness falls within the range defined by low and high 

threshold are painted in grey (Fig. 1.3.6). This functionality allows one to quickly segment an image - to identify its dark, 
medium brightness and white objects. 

 



Fig 1.3.6 Image thresholding by means of sliders 
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1.4. Histogram window 

After loading an image, MaZda computes its histograms, separately for each ROI defined. As an example, consider the 
image shown in Fig. 1.4.1, that contains 4 ROIs. By choosing View=>Histogram menu item, or by pressing Ctrl+H

keyboard keys, one can display a window that contains these histograms (Fig. 1.4.2a - 1.4.2d). 

 

Fig. 1.4.1 An example of MRI image with 4 ROIs superimposed 

a)  



b)  

c)  

d)  

Fig. 1.4.2 Histograms computed for the image and ROI in Fig. 1.4.1 
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1.5. Report window 

Consider the main window after loading the "text0324.ima" MR image and 4-region ROI image, as shown in Fig. 1.5.1. 
To compute texture parameters for these ROI, one can invoke Analysis=>Run menu item. Then MaZda produces a 
report tab-page with a 4-column table (one column for each ROI), that can be browsed through in a report window. This 
window is displayed either by means of View=>Report menu item or by pressing Ctrl+R keyboard keys. The report 

window corresponding to the example image from Fig. 1.5.1 is presented in Fig. 1.5.2. 



 

Fig. 1.5.1 An example of MRI image "text0324.ima" with 4 ROIs superimposed, defined in "newdraw.roi" file 

 

Fig. 1.5.2 Report window generated for the image and ROI in Fig. 1.5.1 

The report window consists of a menu bar and tab-pages, each containing a list of texture parameters computed for 

images analysed during a MaZda session. If, for example, another image, say "text0321.ima", is loaded (Fig. 1.5.3) and 



then analysed, the report window will contain two tab-pages, as shown in Fig. 1.5.4. 

 

Fig. 1.5.3 Main window for "text0321.ima" image and "newdraw.roi" ROI file 

 

Fig. 1.5.4 Report window generated for images "text0324.ima" and "text0321.ima", both analyzed using the 

same ROI, "newdraw.roi" 



Each tab-page of the report window displays the information about the texture analysis options, in its upper pannel. One 

can read, for example, from the panel shown in Fig. 1.5.4 that 

� the image and ROI file names were respectively "text0321.ima" and "newdraw.roi",  

� the image minimum and maximum brigthness values were 1 and 1023,  

� the image was digitally encoded using 11 bits per pixel,  

� the image was normalized before analysis using the "±3 sigma" technique,  

� the co-occurence matrix-derived parameters were computed ...  

et ceatera. 

The lower panel of the report window contains a list of texture parameters and their values computed for each ROI. Most 

of them can be used for texture characterisation, except of area parameters, such as , which merely indicate the 

number of pixels (or pixel neighbourhoods) used for parameters computation. Columns in the lower panel represent 
individual regions of interest, whereas rows represent features computed within these regions. 

The computed parameter values are listed in columns. The number of columns is equal to the number of different color 

ROIs, superimposed on the image. In the case of the examples shown here, the number of ROIs is equal to 4. Typically, 
each ROI corresponds to a separate class of textures; however, it can just be an example of the same class if a number 
of ROIs is superimposed on a homogeneous texture area in an image. Thus each column in the report file should be 
attributed a name corresponding to a texture class the user wants it to represent. This can be done by clicking on the 

column title bar; after that a suitable dialog window is displayed (Fig. 1.5.5). 

 

Fig. 1.5.5 Window for editing the name of the class a feature column is meant to represent 

The column selected can be excluded from further analysis by unchecking the appropriate checkbox in the window of Fig. 
1.5.5. The new class name can be applied to a single column, all columns corresponding to a ROI of a given color, or to 
all columns in the report. 

Any parameter from the list can either be selected ( ) for further inclusion in the analysis, or deselected 

from it ( ). This can respectively be done by cliking on the icon on the left-hand side of the parameter 
name. 

The rows of the parameter table in the lower panel of the repoert window can be highlighted by clicking on the row 

content and/or using the Ctrl or Shift keybord keys in a standard MS Windows® way (Fig. 1.5.6). 

  

Fig. 1.5.6 A set of highlighted rows of texture parameters 

By using the Feature selection=>Select highlighted or Feature selection=>Deselect highlighted menu items, 

one can respectively select the highlighted parameters for further analysis, or exclude them from it (Fig. 1.5.7). 



 

Fig. 1.5.7 The Feature selection menu items of the report window 

The selected (checked on the list) texture parameters can be used as an input to feature selection/reduction procedures. 
There are two such procedures implemented in MaZda: one based on Fisher coefficient (a ratio of between-class to 

within-class variance) and the other that selects parameters that classify the given textures with the smallest arror and 
are least correlated with each other (Fig. 1.5.7). Each of them selects 10 texture parameters from the input list. These 
procedures were previously the core modules of the Convert program. 

The features of the tabs of the report windows can be saved to disk, one by one by using the File=>Save report menu 
item. The selected features only can be saved by means of File=>Save selected menu item. 

The texture parameters selected, either manually or by means of the automated "Fisher"/"POE+ACC" procedures, can be 
further used for texture analysis by means of the B11 program, which can be called from within MaZda by Tools=>B11 
analysis menu item of the report window (Fig. 1.5.8). The maximum allowable number of input parameter to B11 is 30. 

 

Fig. 1.5.8 The B11 analysis menu item of the report window 
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1.6. Image View window 

MaZda not only allows one to compute texture parameters within a ROI, as discussed in Section 1.5. Also, which is a 
very useful functionality, it generates parameter maps which are texture parameters computed in a small window sliding 
over the image. To obtain such maps one has to select proper analysis options in the options window. 

Suppose "271-9-77.bmp" MR image has been loaded to the image panel (Fig. 1.6.1). Assume also GrMean, S(1,0)
AngScMom, S(3,0)Contrast, Mean and Variance features have been selected in the options window (Fig. 1.6.2). After 
running the image analysis using the Analysis=>Run menu item of the main window, the Image View window is 
displayed on the screen. It contains tab pages, each with a feature map, as illustrated in Fig. 1.6.3a-1.6.3e. 

If one points at a given pixel in a feature map by means of mouse-driven cursor, the pixel coordinates and feature value 
are displayed in the status bar of the Viewer window (Fig. 1.6.3). 



 

Fig. 1.6.1 An example of MR image "271-9-77.bmp" 

 

Fig. 1.6.2 An example of the options window 



a)   

b)   



c)   

d)   



e)   

Fig. 1.6.3 Image maps generated for image "271-9-77.bmp" 
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1.7. Image information window 

If an image is loaded into the MaZda working space, one can see the header information extracted from the image file. 

This can be obtained either by selecting the View=>Image info menu item of the main window (Fig. 1.7.1), or by 
pressing the Ctrl+F keyboard keys. The image header information is then displayed in the Image info window, as shown 
in Fig. 1.7.2. 



 

Fig. 1.7.1 An example of MR image "rimml047.ima" and View=>Image info menu item selected 

 

Fig. 1.7.2 The contents of the header of MR image "rimml047.ima" presented in the image information 
window. 
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1.8. B11 window 

If a number of texture features has been selected in the report window, either manually or automatically, one can call 



the B11 program for the obtained data exploration, and eventually texture classification. The B11 analysis menu item 

of the report window can be used for the purpose (Fig. 1.8.1). Once it is invoked, the B11 analysis program window is 
displayed on the screen (Fig. 1.8.2). More information about the functionality and operation of B11 can be found in 

Section 4 of this User's Manual.   

Fig. 1.8.1 The B11 analysis menu item of the report window 

 

Fig. 1.8.2 the B11 analysis program window 
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1.9. Options window 

The options window appears on the screen (Fig. 1.9.1) if Analysis=>Options menu item is selected in the main 

window. It contains 3 tab-pages, corresponding respectively to setting options to compute texture parameters within ROI 
("Features" tab-page), selection of parameters to generate feature maps ("Maps"), and setting options to compute 
parameters derived from wavelet transform ("Wavelets"). The optional parameter values, that affect operation of 
MaZda, can be saved in a *.ini file for further loading when needed. 

 

1.9.1 ROI feature options 



 

Fig. 1.9.1 The options window (features) 

Texture parameters derived from 6 different statistical image descriptors can be computed by MaZda. The parameters 
are derived respectively from 

� image histogram,  

� image gradient,  

� run-length matrix (RLM),  

� co-occurrence matrix (COM),  

� autoregressive model (AR),  

� wavelet transform,  

each calculated for up to 16 predefined ROIs. 

Calculation of features belonging to a selected group can be enabled or disabled by clicking on a corresponding check 
box. As an example, for the settings shown in Fig. 1.9.1, the histogram, RLM and COM features are enabled, whereas the 
gradient-based and autoregressive model features are disabled. 

To compute texture parameters derived from the RL and CO matrices, as well as texture parameters derived from the 
image gradient, the image fragments inside the ROIs are normalized first. The normalization includes 

� image intensity range selection,  

� image quantization, using selected number of bits per pixel.  

To select the intensity range, one has to click on one of the radio buttons inside the Normalisation frame in Fig. 1.9.1. 
There are three normalisation options available in MaZda: 

� default setting, which is the intensity range of the image under analysis, from 1 to N
g
 = 2k, where k is the 

number of bits per pixel used to encode the image under analysis (see Note 1),  

� ±3 sigma option, which is equivalent to the range [µ-3σ, µ+3σ] where µ is the image mean and σ denotes its 

standard deviation (both µ and σ are computed separately for every ROI),  

� 1% – 99% option, which is the range between the brightness level at which image accumulated histogram is 

equal to 1% of its total to the level where the accumulated histogram is equal to 99% of its total (typically, 
different ROIs give different 1%- and 99%-levels).  

The ±3 sigma normalization option is selected in the example of Fig. 1.9.1. 

In the case of computation of AR model parameters, there is only one normalization method employed for ROI 

preprocessing. In this case, each ROI is standardized, independent of the setting of the radio buttons inside the 
Normalization frame in Fig. 1.9.1. To do the standardization, mean value and standard deviation are computed, taking 
into account all the image points inside the ROI considered. Then mean value is subtracted from original image intensity 
(within the ROI) and the differences are divided by the standard deviation. In this way, all the parameters of the AR 
model are confined to the range from -1 to 1, independent of the actual image variance.  



To select the number of bits used for image quantization before computing the RLM (Haralick, 1979), COM (Haralick, 

1973) and gradient features (Lerski, 1993), one has to click on corresponding radio buttons within the respective frame 
inside the Options dialog box. In the example of Fig. 1.9.1, 5 bits per pixel were selected for RLM parameters, 6 bits per 
pixel were used for COM features, and 8 bits per pixel were chosen for gradient-derived parameters. 

Additionally, the COM parameters depend on the distance between pairs of image points that has to be specified to 
compute the co-occurrence matrix (Haralick, 1973). Up to five different values of the distance are supported. For the 
example shown in Fig. 1.9.1, two values of distance parameter are enabled: d = 2 and d = 3. More details about texture 
parameter definitions can be found in Section 3.3 and in references. 

1.9.2 Feature map options 

The feature maps option window is shown in Fig. 1.9.2. Using mouse, one can indicate an element in the tree diagram 
(on the left-hand side of the window), and then activate "select" or "clear" button (on the right-hand side of the window) 

to, respectively, select or unselect group of features for maps generation. Features can be selected in groups (Fig. 1.9.2) 
or individually (Fig. 1.9.3). Values of selected features are computed for a sliding window that is moved in steps over the 
image area. The size of the window and values of steps in horizontal and vertical directions can be adjusted by means of 
arrows of the control elements in the options window (right-hand side of Figs. 1.9.2 and 1.9.3). 

 

Fig. 1.9.2 The options window (feature maps) 

Note 1 

To keep consistency with the formulas used in the standard references (Haralick, 1973), (Haralick, 1979) 
on texture analysis, it is assumed in MaZda that the intensity of image under analysis changes from 1 to 

Ng, where Ng = 2k, and k is the number of bits per pixel. Thus if originally the image intensity changes 

from 0 to Ng-1, MaZda converts this image internally, such that its intensity changes from 1 to Ng. 
Consequently, the summation indices in the formulas listed in Section 3.3 span the range from 1 to Ng. 



 

Fig. 1.9.3 Example of individual feature selection for maps calculation 

1.9.3 Wavelet feature options 

The wavelet-features tab-page of the option window is shown in Fig. 1.9.4. 

 

Fig. 1.9.4 The options window (wavelet features) 

Note 2 

Computation of feature maps is, generally, a time consuming process, especially at large size of "Mask" 
and small value of "Step" (Figs. 1.9.2 and 1.9.3). It is recommended to do some experiments with a small 
number of feature maps (e.g. one or two), to assess the time needed for map generation on a particular 
computer, before attempting calculation of a large number of maps. 
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2. Getting started with MaZda 
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2.1. Input and output data 

MaZda allows computation of selected statistical parameters of digital image texture, within a region of 

interest (ROI) defined by the user. Up to 16 regions of interest can be specified, as shown in Fig. 2.1.1. 

They are labelled with different colours – to be distinguished from each other. 

a)  

b)  

Fig. 2.1.1 An example of a digital image (a) and 6 ROIs within the field of it (b). 

The input to the program are then two images. One is the image to be analysed. It can be loaded from 

disk in one of 12 file formats supported. The other is the ROI image. This image can either be defined by 

the user or loaded from a disk file. Logically, the ROI image is superimposed by the program on the image 

under analysis. 

The statistical features, calculated for each ROI by MaZda are listed in columns, in the form of a table. 

Such tables, with added information about the analysis options, are displayed in a report window. They 

can be saved on disk as a text file (analysis report file). The default name of the report file is *.par. This 

is one of the forms of ouput information generated by MaZda. 

Typically, a report file contains a very large amount of data which is almost impossible to study by the 



user directly. For example, the number of parameters included in such file is about 300. Then, there is a 

need for retaining only the most relevant parameters in the context of textures under consideration. To do 

that, there are two procedures, "Fisher" and "POE+ACC" that can be run from Feature selection menu 

item of the report window. They produce a list of 10 parameters each, placed in a text file with extension 

*.sel. These files form the second form of output information from MaZda. 

The *.par and *.sel file can be used as an input to any statistical analysis program to do further image 

analysis, e.g. aimed at texture classification. The simplest, yet fully useful solution is to apply MS Excel®

for the processing of the analysis report files. For the user convenience, the B11 program has been 

designed and linked to MaZda. This program takes *.sel files as input and allows one data preprocessing 

(with PCA, LDA and NDA techniques) and texture clasification (k-NN and artificial neural network 

classifiers). It can be called from Tools=>B11 analysis menu item of the report window, and is 

described in Section 4 of the Users' Guide. 

Yet another information that MaZda extracts from the input images are their histograms computed for 

each ROI. 

 

Fig. 2.1.2 A mean-gradient feature map computed for Fig. 2.1.1a (the input image was 

quantized to 4 bits per pixel, prior to feature computation) 

MaZda allows also computation of feature maps, obtained from the input image. A sliding window of 

adjustable size is moved (with adjustable steps) along the x and y coordinates. For each window position, 

selected image features are computed and presented in a form of another image - the feature map. An 

example of feature image (map), which is in this case a gradient magnitude computed for the image of 

Fig. 2.1.1(a), is demonstrated in Fig. 2.1.2. The feature maps are displayed as tab-pages of the Image 

View window. 
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2.2. Loading the image 

There are 4 ways of loading an image to be analyzed into the MaZda working space:  

� selecting File=>Load image... menu item and going through a standard MS Windows® procedure, 

� clicking on  button and going through a standard MS Windows® procedure, 
 

� double clicking on a image file name registered as MaZda file name (this option will not work on 

the first run of the software on a given computer),  

� indicating the image file name on the list in the MS Windows Explorer® program window, pressing 

the left-hand mouse button, moving the cursor to inside the MaZda main window, and releasing 

the left mouse button ("drag'n'drop" option). 

2.2.1. Raw image options 

The assumed structure of a raw-image file is illustrated in Fig. 2.2.1. It has a form of a vector of 

consecutive binary words used to encode the image data, with a header placed before the images. 

 

Fig. 2.2.1 Assumed structure of a raw-data image file 

Each word represents the brightness of corresponding image pixels. The words can be either 8-bit or 16-

bit long. The choice of the word length ("Bits per pixel") can be made by means of two radio-buttons 

located in the upper right corner of the dialog window (Fig. 2.2.2). In the case of 16-bit (2-byte) words, 

the order of the bytes can be selected by means of another pair of radio buttons, indicated as "Bytes 

order" in Fig. 2.2.2. The "Intel" option denotes the arrangement in which the most significant byte (MSB) 

precedes the least significant byte (LSB) in every word stored in a file. The "Motorola" option is the 

opposite: the LSB comes first, then MSB follows. 

The header information is not read by MaZda; however, the length of the header should be provided by 

the user to give the program proper address reference for reading the images ("Header length"). In the 

case of no header, the zero digit should be entered in the edit box. The size of the images (in pixels) can 

be entered using the upper pair of edit boxes in the dialog window ("Image dimensions" in Fig. 2.2.2) -

horizontal dimension on the left, and vertical dimension on the right. Finally, the lower edit box ("Image 

number") allows users to indicate the number of the image that is to be read by MaZda from the input file, 

first image being numbered by 0 (Fig. 2.2.1). 



 

Fig. 2.2.2 Dialog window of File=>Raw options... menu item 

2.2.2. Loading color image 

MaZda is capable of analysis of gray-scale image only. However, when loading the color image bitmap the 

user may select what kind of information or color channel to load into MaZda. While loading the color 

image MaZda converts it into a gray-scale with one of eight algorithms. Thus, it may convert color image 

according to CCIR Recommendation 601-1 (Y channel), it may extract red (R), green (G), blue (B), U or V 

color components. Moreover, it may compute Saturation (S) or Hue (H) of color image. The Fig. 2.2.3 

shows an example color image and its color channels computed by the MaZda image loader. 

 

Fig. 2.2.3 Example of color image and its color channels 

To switch a color conversion mode one has to select File->Color conversion... option from the MaZda 

menu, and then, within a Color conversion dialog window, to select appropriate color conversion 

algorithm (Fig. 2.2.4). MaZda will load a selected color channel of the opened image after pressing the 

Reload button. Pressing OK button will not automatically reload image. 



 

Fig. 2.2.4 Color conversion dialog window 
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2.3. Editing ROI 

It is possible to define up to 16 regions in the image (image fragments) for which texture parameters will 

be computed. These regions of interest (ROIs) are marked with different colours. (Immediately after any 

image is loaded, only one region - marked in red - covering the whole image is defined. It can be cleared 

or reset by means of approriate Edit menu items.) 

To define or redefine the ROI one has to  

� choose the number and colour of the region to define (or redefine) from the region panel (at the 

bottom of the window) by clicking ROI switch (a row of coloured boxes with numbers on it),  

� use drawing tools (left panel) to draw the ROI shape on the surface of the image.  

As an example, consider the image in Fig. 2.3.1. To better see the image structure, switch the image 

palette to three-level mode , adjust “Min” / “Max” track-bars (Fig. 2.3.2), choose “Draw line” tool, 

adjust the line thickness and paint the ROI over the image (Fig. 2.3.3). 

Basic mathematical-morphology operators (erosion, dilation, opening and closing, e.g. Giardinia 1988) can 

be applied to the manually-painted ROI - to fill the holes and smooth boundaries - by pressing the 

button (available from version 3.08 onwards, as can be seen in Fig. 2.3.1). 

 



Fig. 2.3.1 An MR image of a trabecular bone 

 

Fig. 2.3.2 The MR image of Fig. 2.3.1 adjusted for editing a ROI 

 



Fig. 2.3.3 Two ROIs edited by means of a "Draw line" tool for MR image of Fig. 2.3.1 

Any region can be moved (“Move” icon), copied (“Copy” icon) or deleted (click on “Move” icon and move 

chosen region outside of image border). Also, a fragment of chosen region can be deleted (choose “Clear” 

and use any drawing tool for clearing out a fragment of region). 

The regions can be defined as non-overlapping or overlapping (“Non overlapping ROI” and “Overlapping 

ROI” icons). If non-overlapping option is chosen, when ROI is being drawn, it destroys other regions 

drawn at its location. If overlapping option is chosen, drawing will produce regions that share a common 

image area. 

Any region may be switched on and off by clicking ROI on/off box (coloured, smaller box without number 

on the panel at the bottom of the window). Please note that switching the region off doesn’t affect 

the analysis process, the region is still taken into consideration during computation of texture 

parameters! 

The image histogram plot within regions may be viewed View=>Histogram. The histogram is updated 

every time the region changes. 

Every region can be assigned a class name. To define a class name of a region, double-click or right-click 

on the ROI switch box and fill up the form displayed with a name (Fig. 2.3.4). The region name appears 

when the mouse cursor stays over ROI switch box for a while. Regions defined together with their names 

can be saved to a file or loaded from a file (File=>Save ROI... and File=>Load ROI... menu items). 

 

Fig. 2.3.4 Dialog box for giving a name to ROI 
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2.4. Image analysis 

Image analysis covers two tasks: texture parameter computation within ROIs and feature map generation. 

Before running the analysis, by selecting Analysis=>Run menu item, one has to select the required 

analysis options using the Analysis=>Options menu item. 

After analysis is done, its results are displayed in Report and/or Image View windows. 
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2.5. Parameter selection and reduction 

Selection of parameters can be done manually, as described in Chapter 1.5, or automatically, using four 

selection methods. First one is based on selection of feature subsets (they can contain one, two or three 

features) which provide the lowest classification error with 1-nearest neighbor classifier. Second method is 

based on Fisher coefficient, third one uses both minimisation of classification error probability and average 

correlation coefficients (POE+ACC), and the fourth one implements the Mutual Information coefficient 

(MI). 

In the case of automatic selection, calculations are performed for all features that have been selected in 

parameter files opened in the Report window. All those files must have the same structure, i.e. the same 

definition and number of features. 

Texture classes are recognised based on ROI names. By default, ROI names are numbered from 1 to 16. 

They correspond to different ROI colours (red ROI corresponds to 1, green ROI corresponds to 2 and so 

on). ROI name can be manually changed to provide more meaningful names to texture classes. Particular 

ROI can be disabled for discriminant analysis. The procedure for ROI name changing and disabling is 

described in Chapter 1.5 (Fig. 1.5.5). The number of texture classes (different ROIs) is limited to 16. 

To peform feature selection based on automatic techniques, one should use Feature 

selection=>Optimal subsets (next, number of features in the subset should be selected), Fisher, 

Feature selection=>Fisher, Feature selection=>POE+ACC or Feature selection=>Mutual 

Information menu items in the Report window. After that, one of six windows shown in Fig. 2.5.1, will 

appear. 

a)  



b)  

c)  

d)  



e)  

f)  

Fig. 2.5.1 Window of features (a), feature pairs (b), feature triples (c) with lowest 1-NN 

classification error; features with: Fisher coefficients (d), POE+ACC coefficients (e), Mutual 

Information coefficients (f) 

These windows contain respectively a list of up to 10 features with largest F coefficients or a list of up to 

10 features with lowest POE+ACC coefficients, depending which selection method has been applied. After 

pressing Accept button, only the features displayed in this window will be selected. Selected features can 

be saved as a *.sel file using File=>Save selected menu item. 

Manual and automatic feature selection techniques can be mixed, i.e. some features can be manually 

disabled (i.e. unchecked in the Report window) before automatic feature selection analysis. It is also 

possible to manually disable (i.e. uncheck on the list in the Report window) features chosen by the 

Optimal subsets/Fisher/POE+ACC/Mutual Information methods. 

During automatic analysis, the error message shown in Fig. 2.5.2 can appear. It means, that 

� there is only one ROI defined (one texture class identified),  
� there is only one sample of some texture class  

To continue automatic selection in such situation, one should define or enable more ROIs (texture classes) 

or load more samples of a given texture. 



 

Fig. 2.5.2 Error message window 
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2.6. Analysis automation 

The process of texture analysis can be automated by running a so-called macro. This can be done by 

choosing File=>Run macro... menu option from the main menu. Macro is a text file, usually with .txt

extension, which contains consecutive MaZda commands. It governs the required operations of loading 

and saving files, setting analysis options, running calculation of texture parameters, and so on. 

The macro commands that can be recognised by MaZda are as follows:  

1. LoadImage file_path_and_name – loads an image for analysis from a given file,  

2. LoadROI file_path_and_name – loads regions of interest from a given file,  

3. LoadOptions file_path_and_name – loads options from a given file,  

4. LoadReport file_path_and_name – loads a report into the report window,  

5. ColorChannel [arg = Y, R, G, B, U, V, H or S] – selection of color conversion mode,  

6. ReloadImage – reloading an opened image (e.g. after changeing a color conversion mode),  

7. RunAnalysis – starts the analysis process,  

8. Execute file_path_and_name argument_list – executes program from a given file,  

9. AggregateReports – joins data from two reports,  

10. SaveImage – saves an opened image,  

11. SaveSelected file_path_and_name – saves selected features to a given file,  

12. SaveReport file_path_and_name – saves report from opened tab-page of report window to a 

given file,  

13. SaveMap file_path_and_name – saves feature map from opened tab-page to a given file,  

14. CloseReport – closes opened tab-page of report window,  

15. CloseMap – closes opened tab-page of feature map,  

16. Exit – unconditional MaZda termination.  

Any line starting with ‘/’ or ‘;’ is a comment which is ignored by the interpreter. 

Plugins are implemented in MaZda through its macro technology. Macro files given a “.plugin” extension, 

located in MaZda’s working directory are recognized as plugins, and are accessible from the MaZda Tools

menu (Fig. 2.6.1). 



 

Fig. 2.6.1 MaZda menu extended with plugins 

Examples: 

// Load_and_analyze.txt - MaZda macro example 

// The macro loads image, region of interest and options set, 

// performs the textural analysis and saves its results. 

LoadImage siem2.dcm 

LoadROI testroi.roi 

LoadOptions opctions1.ini 

RunAnalysis 

SaveReport result1.par 

SaveMap map3.bmf 

CloseMap 

SaveMap map2.bmf 

CloseMap 

SaveMap map1.bmf 

CloseMap 

 

 

// View_in_notepad.txt - MaZda macro example 

// Simple macro that saves a report to a file 

// and opens it with a notepad editor. 

SaveReport temp.par 

Execute notepad.exe temp.par 

 

 

// Color_analysis.plugin - MaZda plugin example 

// The plugin analyzes color image YUV channels. 

// It joins all the computed features within a single report. 

ColorChannel Y 



ReloadImage 

RunAnalysis 

ColorChannel U 

ReloadImage 

RunAnalysis 

AggregateReports 

ColorChannel V 

ReloadImage 

RunAnalysis 

AggregateReports 

ColorChannel Y 

ReloadImage 
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3. Theoretical background 
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3.1. Texture analysis methods 

A literature survey, on main techniques of image texture analysis has been reported by A. Materka and M. 

Strzelecki in Brussels, during one of the COST B11 workshops in 1998. It is available in pdf form at 

http://www.eletel.p.lodz.pl/cost/pdf_1.pdf as Texture analysis methods - a review. 
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3.2. Feature reduction methods 

The MaZda software generates almost 300 texture parameters. With such a large number of features, it is 

very difficult to predict, which parameters will be most useful for texture classification. Also, the large 

number of features requires very large number of data samples to provide reliable discriminant analysis 

results, from the statistical point of view. The required large number of samples are not normally available. 

Finally, almost 300 features are difficult to manage (for presentation, displaying, analysis). For these 

reasons, there is a need for feature reduction, to provide a compact parameter set useful for texture 

discrimination and classification. 

Generally, there are two approaches for feature reduction. First, called feature selection, is based on 

choosing of some features according to given mathematical criterion. As a consequence, a subset of 

features is obtained, which best satisfies such a criterion. Examples of feature selection methods are the 

one based on Fisher criterion and another one, based on minimisation of classification error and correlation 

coefficient (POE+ACC). Both methods are further described in this chapter. 

Yet different feature reduction approach is called feature extraction or projection. In this case, the original 

feature space is transformed into a different space, of lower dimension compared to the input space. This 

provides a set of new features, smaller in number than the original feature set. Feature extraction 

techniques of ths type, namely principal component analysis (PCA), linear discriminant analysis (LDA) and 

nonlinear discriminant analysis (NDA) are implemented in B11 program and described in B11 help file. 

Optimal subsets 

This feature selection method is based on selection of feature subsets (from the whole geature set), which 

can contain one, two or three features. These subsets are optimal in the sense that they provide minimal 

classification error when 1-nearest neighbor (1-NN) classifier is used. 

Using this MaZda option, up to 10 features (feature pairs or feature triples) with the lowest 1-NN 



classification error can be selected. To activate this option, one should use Feature selection=>Optimal 

subsets=>Single feature/Feature pairs/Feature triples menu item in the Report window.  

Fisher coefficient 

This feature selection method is based on Fisher coefficient. It is defined as a ratio of between-class 

variance to within-class variance (Schürmann 1996) 

 

where D denotes between-class scatter, V - within-class variance, µµµµ
i
 and V

i
 - mean and variance of class i, 

P
i
 - probability of class i (ratio of number of data samples from class i to the number of all data samples).  

Using this MaZda option, up to 10 features with the largest Fisher coefficient can be selected. To activate 

this option, one should use Feature selection=>Fisher menu item in the Report window.  

Low POE+ACC feature selection method 

This method is based on minimisation of both classification error probability (POE) and average correlation 

coefficients (ACC) between chosen features (Mucciardi 1971, Dash 1997). The first feature, f1, is chosen to 

minimise POE for all classes: 

 

where POE(f
j
) is the probability of classification error for feature f

j
. This probability is defined as a ratio of a 

number of not properly classified samples to the whole number of samples in the analysed data set, using 

only feature f
j
 for classification. Fig. 3.2.1 shows sample distribution of feature fj for two classes. Samples 

of the feature fj marked in blue belong to class 1 while the samples marked in red belong to class 2. The 

samples marked in black can be assigned both to class 1 or 2. In this case, these samples can not be 

properly classified. The POE calculated for this feature is given by the following equation: 

 



 

Fig. 3.2.1 A sample distribution of feature f
j

 

The next feature is then selected by minimising the following sum for all features, excluding f
j
:

 

 

The |CC(f1, f
j
)| is the absolute value of correlation coefficient between previously chosen feature f1 and the 

new feature f
j
. The n-th feature is chosen by minimising the following sum for all remaining features 

(except for the features already selected):  

 

where the averaged sum is extended for correlation coefficients between previously selected features and 

feature f
j
. This sum is called an average correlation coefficient (ACC). 

To control influence of POE and ACC components on the feature selection process, two weight values can 

be added to the previous formula: 

 

In the present version of Convert module implemented in MaZda it is assumed w
1
=w

2
=0.5.

 

Using this technique, features with the lowest POE+ACC coefficient will be selected. To activate this option 

in MaZda, one has to select Feature selection=>POE+ACC menu item in Report window. 

Mutual information measure 

Mutual information is a measure of dependence between two or more random variables. In the case of two 

random variables X and Y, it is defined as follows (Tourassi 2001): 

 



where H is the entropy. It can be considered, that random variables X stores values of texture features, 

while Y stores the classification decision. Then, large value of mutual information between texture feature X

and class category variable Y means that this feature carries information about class membership (its 

values are correlated with given class categories). In consequence, such a feature is useful for 

classification. On the other hand, when class category does not depend on the feature value X, mutual 

information equals to zero because H(X,Y)=H(X)+H(Y) for independent variables. 

In MaZda, the mutual information for each feature f
j
 is estimated according to the formula (Tourassi 2001, 

Kwak 2002): 

 

where P means the probability, f
j
d is discretised value of feature f

j
, Nb is a number of histogram bins used 

for feature discretisation., d={c
1
, c

2
, ..., c

Nc
} means the class category, and Nc is the total number of 

categories (classes). In this version of Mazda Nb is constant and equals to round[log
2
(M)+1], where M is a 

total number of samples of feature f
j
 (Tourassi 2001). 

Using this MaZda option, up to 10 features with the largest Mutual Information coefficient can be selected. 

To activate this option, one should use Feature selection=>Mutual Information menu item in the 

Report window. 
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3.3. Texture parameters summary 

MaZda allows computation of a variety of statistical parameters that are derived from image histogram, 

absolute gradient, run-length matrix co-occurrence matrix and autoregressive model (Table 3.3.1). One of 

the latest additions to MaZda are texture parameters derived from wavelet analysis. 

The run-length matrix-based parameters are computed 4 times for each ROI (for vertical, horizontal, 45-

Table 3.3.1. Texture parameters computed by MaZda

Histogram Absolute gradient Run-length matrix
Co-occurrence 

matrix

AR 

model

� mean  

� variance  

� skewness  

� kurtosis,  

� 1-% 

percentile  

� 10-% 

percentile  

� 50-% 

percentile  

� 90-% 

percentile  

� 99-% 

percentile  

� mean  

� variance  

� skewness  

� kurtosis  

� percentage of pixels 

with nonzero 

gradient.  

� run length 

nonuniformity  

� grey level 

nonuniformity  

� long run 

emphasis  

� short run 

emphasis  

� fraction of image 

in runs  

� angular second 

moment  

� contrast  

� correlation  

� sum of squares  

� inverse 

difference 

moment  

� sum average  

� sum variance  

� sum entropy  

� entropy  

� difference 

variance  

� difference 

entropy  

� θ
1
  

� θ
2
  

� θ
3
  

� θ
4
  

� σ  



degree and 135-degree directions). The co-occurrence matrix-based parameters are [computed up to 20 

times, for (d,0), (0,d), (d,d), (d,-d) where the distance d can take values of 1, 2, 3, 4, and 5]. 

Definition and discussion of the above parameters can be found in (Haralick 1973, Haralick 1979, Hu 1994, 

Lerski 1993). A quick texture parameter reference is provided below for the user convenience. 

3.3.1 Histogram-based features 

In the formulas that follow, p(i) is a normalized histogram vector (i.e. histogram whose entries are divided 

by the total number of pixels in ROI), i=1,2,..., N
g
, and N

g
 denotes the number of intensity levels. 

Mean:  

Variance:  

Skewness:  

Kurtosis:  

 

3.3.2 Gradient-based parameters 

For the gradient feature calculation the following neighborhood for image pixel x(i,j) is defined: 

 

Based on this neighborhood, the absolute gradient value (ABSV(i,j)) is calculated for each pixel: 

a) for 5x5 pixel neighborhood:  

Note 

To keep consistency with the formulas used in the standard references (Haralick 1973, 

Haralick 1979) on texture analysis, it is assumed in MaZda that the intensity of image under 

analysis changes from 1 to Ng, where Ng = 2k, and k is the number of bits per pixel. Thus if 

originally the image intensity changes from 0 to Ng-1, MaZda converts this image internally, 

such that its intensity changes from 1 to Ng. Consequently, the summation indices in the 

formulas listed below span the range from 1 to Ng. 



b) for 3x3 pixel neighborhood:  

The ABSV3 definition is used in this version of MaZda. For the ABSV=ABSV3 matrix of M elements (which 

contains absolute gradient values for ROI pixels), the gradient features are defined as follows:  

Mean absolute gradient: 

 

Variance of absolute gradient: 

 

Skewness of absolute gradient: 

, 

Kurtosis of absolute gradient: 

, 

where ROI is a region of interest. 

Percentage of non-zero ABSV matrix elements (Grads>0) 

 

3.3.3 Run length matrix-based parameters 

Let p(i,j) be the number of times there is a run of length j having grey level i. Let N
g
 be the number of grey 

levels and N
r
 be the number of runs. Definitions of the parameters of the run-length matrix p(i,j), as 

adopted in MaZda, are given below. 

Short run emphasis inverse moments: 

 

Long run emphasis moments: 

 

Grey level nonuniformity: 



 

Run length nonuniformity: 

 

Fraction of image in runs: 

 

The coefficient C is defined as 

 

The above 5 features are calculated for 4 directions: horizontal (Horzl_), vertical (Vertl_), slanted at 45 

degrees (45dgr_) and slanted at 135 degrees (135dgr_). The RL feature name in MaZda software contains 

a prefix that defines direction and feature type, for example 45dgr_RLNonUni means the run length 

nonuniformity calculated for 45-degree direction. 

 

3.3.4 Co-occurrence matrix-derived parameters 

The second-order histogram is defined as the co-occurrence matrix h
dθ
(i,j) [1]. When divided by the total 

number of neighboring pixels R(d,θ) in ROI, this matrix becomes the estimate of the joint probability, p
dθ

(i,j), of two pixels, a distance d apart along a given direction θ having particular (co-occurring) values i and 

j. Formally, given the image f(x,y) with a set of N
g
 discrete intensity levels, the matrix h

dθ
(i,j) is defined 

such that its (i,j)th entry is equal to the number of times that 

 and , 

where . 

This yields a square matrix of dimension equal to the number of intensity levels in the image, for each 

distance d and orientation θ;. In MaZda, the distances d = 1, 2, 3, 4 and 5 pixels with angles θ; = 0°, 45°, 

90° and 135° are considered. Reduction of the number of intensity levels (by quantization to fewer levels of 

intensity) helps increase the speed of computation, with some loss of textural information. 

The co-occurrence matrix-derived parameters computed by MaZda are defined by the equations that 

follow, where µ
x
, µ

y
 and σ

x
, σ

y
 denote the mean and standard deviations of the row and column sums of 

the co-occurrence matrix, respectively [related to the marginal distributions p
x
(i) and p

y
(j)].  

Angular second moment: 

 

Contrast: 



 

Correlation: 

 

Sum of squares: 

 

Inverse difference moment: 

 

Sum average: 

, 

where 

 

Sum variance: 

 

Sum entropy: 

 

Entropy: 

 

Difference variance: 



 

where µ;
x-y
 is a mean value of difference distribution p

x-y
:

 

 

Difference entropy: 

 

 

3.3.5 Autoregressive model parameters 

The autoregressive (AR) model assumes a local interaction between image pixels in that pixel intensity is a 

weighted sum of neighbouring pixel intensities. Assuming image f is a zero-mean random field, an AR 

causal model can be defined as 

 

where f
s
 is image intensity at site s, e

s
 denotes an independent and identically distributed (i.i.d.) noise, N

s

is a neighbourhood of s, and θθθθ is a vector of model parameters. The local neighbourhood for AR model 

implemented in MaZda, represented by 4 parameters, is shown in Fig. 3.3.1. Shaded area in Fig. 3.3.1 

indicates region where valid causal half-plane AR model neighbourhood may be located, in general.  

 

Fig. 3.3.1. Local neighbourhood of image element f
s
 

 

Using the AR model for image segmentation consists in identifying the model parameters for a given image 

region and then using the obtained parameter values for texture discrimination. In the case of simple pixel 

neighbourhood shown in Fig. 3.3.1, that comprises 4 immediate pixel neighbours, there are 5 unknown 

model parameters – the standard deviation σ of the driving noise e
s
 and the model parameter vector θθθθ=

[θ
1
,θ

2
,θ

3
,θ

4
]. The parameters can be estimated by minimizing the sum of squared error 

 

which leads to the following linear equations: 



  

where w
s
 = col[f

i
, i∈N

s
], and the square N×N image is assumed. The above set of equations is numerically 

solved in MaZda for each ROI of interest. 

As an example, AR model parameters were used in [5] for unsupervised texture segmentation. 

 

3.3.6 Wavelet parameters 

The discrete wavelet transform (DWT) is a linear transformation that operates on a data vector whose 

length is an integer power of two, transforming it into a numerically different vector of the same length. It 

is a tool that separates data into different frequency components, and then studies each component with 

resolution matched to its scale. DWT is computed with a cascade of filters followed by a factor 2 

subsampling (Fig 3.3.2). 

 

Fig. 3.3.2 DWT tree. 

H and L denotes high and low-pass filters respectively. Boxes after each filter denote subsampling. Outputs 

of these filters are given by the following equations 

 

Elements a
j
 are used for next step (scale) of the transform and elements d

j
, called wavelet coefficients, 

determine output of the transform. l[n] and h[n] are coefficients of low and high-pas filters, respectively. 

One can assume that on scale j+1 there is only half of the number of a and d elements at scale j. This 

causes that DWT can be done until only two a
j
 elements remain in the analyzed signal. These elements are 

called scaling function coefficients. 

DWT algorithm for pictures is similar. The DWT is performed firstly for all image rows and then for all 

columns (Fig.3.3.3). 



 

Fig. 3.3.3 Wavelet decomposition for two-dimensional pictures. 

In this version of MaZda, only one set of DWT derived features is considered. It is a vector, which contains 

energies of wavelet coefficients calculated in subbands at successive scales. 

To compute the wavelet features in the first step, Harr wavelet is calculated for whole image. As a result of 

this transform there are 4 subband images at each scale (Fig.3.3.4). 

 

Fig. 3.3.4 Subband images. 

Subband image aLL is used for DWT calculation at the next scale. 

 

For a given image, the maximum of 8 scales can be calculated by MaZda. The Harr wavelet is calculated 

only if output subbands have dimensions at least 8 by 8 points. 

In the next step, energy  of aLL, dLH, dHL and dHH is calculated at any considered scale in marked ROIs.

 

 



where n is the number of pixels in ROI, both at given scale and subband. 

Of course, ROIs are reduced in size in successive scales in order to correspond to subband image 

dimensions. In a given scale the energy is calculated only if ROI at this scale contains at least 4 points. 

Output of this procedure is a vector of features containing energies of wavelet coefficients calculated in 

subbands at successive scales. 

 

Fig. 3.3.5 Example of ROI reduced in successive scales 
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B11 program for data analysis and classification 

B11 - program for data analysis and classification 

4.1. Introduction 

Program b11 has been developed for quantitative analysis of magnetic resonance images. It is devised to be one of the 

software tools for carrying out research within the framework of COST B11 European project "Quantitation of Magnetic 
Resonance Image Texture" (1998-2002).  

It is assumed that any magnetic resonance image (MRI) investigated comprises a number of nonoverlapping, 
homogeneous regions. The regions differ from each other in terms of their texture.  

Apart from its perceptual properties, such as coarsness, granulation, regularity, etc., the image texture can be 

quantitatively described by means of local statistics of the image. These statistics, e.g. parameters derived from the so-
called co-occurence matrix, are the texture features. A program called MaZda was developed to compute more than 250 
different features for an image. Feature values obtained from MaZda can be stored in a text file.  

Usually, only a small fraction of features calculated by MaZda can be used to distinguish textures present in an 
investigated image. The remaining features do not carry the discriminative information with regard to the textures at 
hand. Also, it is very time-consuming and difficult to analyse feature vectors in a high-dimensional space. Therefore, yet 
another program, Convert, is used to pre-select a subset of features (e.g. no more than 10) from MaZda output file to 

form a low-dimensional feature vector, for more detailed analysis by means of b11. In MaZda verion 3, Convert has 
been integrated with MaZda for more convenient parameter set selection and reduction. 

The input to b11 program is a text file (produced either by Convert, produced automatically by MaZda or prepared 
manually) that contains feature vectors, each representing a different category (class) of textures. The program 
investigates this input-data file to assess the features ability to distinguish the texture categories. The Fisher coefficient 
is calculated to quantitatively describe discriminative power of the features. Three feature vector transformations are 
available in b11 to transform the data to a new feature space, in order to either reduce the feature vector dimension or 

increase the discriminative power. These are principal component analysis (PCA), linear discriminant analysis (LDA) and 
nonlinear discriminant analysis (NDA). 

Program b11 also allows performing classification tests on the input data using different classifiers, such as k-NN
classifier.  

The three programs being developed within COST B11 (MaZda, Convert and b11) will be integrated in future to made a 
single software tool for MRI texture analysis. Their independent development helps better utilisation of limited human 
resources within the 'Software and Statistics' working group of the COST B11 action. 

B11 - program for data analysis and classification 

4.2. Input and output data 

The input to b11 program is a text file of predefined structure. Such a file contains data organized in four logical blocks: 
label, feature numbers and names, category numbers and names, and feature values. An example of the contents of an 

input file (m25.sel) is presented in Fig. 4.2.1. The m25.sel file contains 25 feature vectors, each of 5 elements long. 
The feature vectors represent 5 data categories, each category represented by 5 vectors. 

The *label keyword (identifier) must be placed in the first line of the file. Second line contains the user-defined label 
(tag) attached to the file, which is ignored by b11.  

The third line contains the *features keyword. Then a list of feature names follows, such that each line starts with a 
number of the feature and its name.  



The *categories identifier starts the next block, which contains all the categories listed, line by line, number preceding 

the name. 

Feature vectors come after the *data identifier. First element of each row is the number of category (class). Elements of 

the feature vector are then placed in each row, in an ascending order (feature #1 placed in column 2, feature #2 in 
column 3, etc.). 

The *end identifier must be placed at the end of the input file. Contents and structure of input files are checked for 

some errors during loading. 

 

Fig. 4.2.1. Contents of m25.sel input file. 

After loading any input file, its text is displayed in the left (input) panel of the main window of b11 program. (It is 
displayed using blue-color font if the file contains errors.) 

Depending on analysis or classification procedure selected, b11 produces an output report which is displayed in the 
right-hand panel of the main program window. Reports can be saved as text files. The extension part of a file-name 

corresponds to analysis procedure that produced that file: 

� *.rda: raw-data analysis report,  

� *.pca: principal component analysis report,  

� *.lda: linear discriminant analysis report,  

� *.nda: nonlinear discriminant analysis report,  

� *.cls: classification report.  

The *.nda files, as well as those *.cls files which were generated by neural-network classifiers, contain the information 
about architecture and weights of neural networks. These files are needed for testing of classifiers trained in, 

respectively, Analysis|NDA, Classification|ANN: one-class (training) and Classification|ANN: n-class (training)
options. 



B11 - program for data analysis and classification 

4.3. Getting started with b11 

The main window of b11 is displayed on the computer screen once the program is executed. It contains a menu bar with 
Files, Options, Analysis, Classification, About, Exit and Help menu items, and two panels for displaying processed 
information. The left-hand (input) panel will contain the input data. Reports from analysis/classification will be displayed 
in the right-hand (output) panel.  

Load the supplied m25.sel input file (use Files|Get Input File menu items and go through a standard MS Windows 
'load file' dialog). The contents of the file will appear in the left-hand panel of the main window of b11 (Fig. 4.3.1).  

 

Fig. 4.3.1. The main window of b11 after loading the m25.sel file. 

Now select Analysis|Raw data menu items. A report of the analysis of the input data will be displayed in the right-hand 
panel of the main window (Fig. 4.3.2), and a graphic window will appear on the screen (Fig. 4.3.3). The plot shows 5 
data clusters in the (teta1, teta2, teta3) space, corresponding to 5 data categories defined in the input file. Each number 

on the plot represents a unique feature vector and the category it belongs to. Click the Flip "teta2" axis menu item of 
the graphics window. Now the plot will show the clusters from another perspective, to better visualize the data 
categories (Fig. 4.3.4).  



 

Fig. 4.3.2. Main window of b11 after running 'Raw Data' analysis of m25.sel file (all features enabled). 

 

 

Fig. 4.3.3. Clusters of data vectors in (teta1,teta2,teta3) space for m25.sel file. 

 



 

Fig. 4.3.4. Clusters of data vectors in (teta1,teta2,teta3) space for m25.sel file (flipped teta2 axis). 

The report displayed in the right-hand panel of the main window of b11 can be saved on disk by using Files|Save 
Report main menu items. 

Other analysis and classification procedures can be invoked by using appropriate menu items. 

B11 - program for data analysis and classification 

4.4. Analysis 

The maximum number of features that can be processed by b11 is limited to 30. By using Options menu item, and 
disabling some of the features present in input file, one can further reduce the number of features considered for 

analysis to Nx, which however can not be smaller than 2. Each Nx-dimensional feature vector x
i
=[x

i1
, x

i2
, ..., x

iNx
] is 

allocated to feature category d
i
, where d

i
∈{c

1
, c

2
, ..., c

Nc
} and Nc is the total number of categories (classes). The 

maximum number of categories is 16 in the present version of b11. The number M of pairs {x
i
, d

i
}, i=1,2,...,M is limited 

to M
max

=2000. The examples {x
i
, d

i
}, i=1,2,...,M, so-called patterns, form the training set for classifiers, and M is the 

size of this set. 

Assume there are M
k
, k=1,2,...,Nc training patterns for category c

k
, such that M

1
+M

2
+...+M

Nc
=M. Mean µµµµ(k) and 

standard deviation σσσσ(k) vectors are computed for each category. Pooled mean µµµµ and pooled standard deviation σσσσ are also 
calculated using all M patterns, and applied for feature standardization. Let x'

i
 be a standardized feature vector. Its p-th

element, p=1,2,...,Nx is computed as follows 

. 

To evaluate the selected features ability to discriminate the categories of interest, Fisher F coefficient is computed for the 

training set. It is defined (Shürmann 1996) as the ratio of mean-squared between-class distance D2 (between the class 

means) to the mean of mean-squared within-class distances V
k
2 (between the samples x of class k and the 

corresponding class mean µµµµ(k)).  

 

4.4.1. Raw Data Analysis 

For this analysis type, Fisher coefficient is calculated for the original data included in the input file. The features can be 

standardized or not, depending on user choice (options window). 



Raw data analysis example 

Load the supplied m25.sel input file as described in Getting started help section. Click Options menu item and disable 

teta2 and teta4 features (Fig. 6.2. in Options help section). Close options window and activate Analysis|Raw Data
menu items. Close graphics window. The report file will be displayed in the right-hand panel of the program main window 
(Fig. 4.1). It can be saved on disk by using Files|Save Report menu items. 

The first line of the report file contains the header and information about the type of analysis (Fig. 4.1). Input file name 
is included in the second line. Third line gives information about the number of features enabled for analysis. These 
features are listed in the subsequent lines (3 lines in the present example). Each line of this type contains feature name 
(e.g. sigma), its number in the reduced feature set (#3), the number in the input file data set (#5), pooled mean 

(p.mean), and pooled standard deviation (p.std). In the following line of the report file (7 in this example), information is 
displayed about feature normalization prior to analysis. Finally, the value of Fisher coefficient is displayed in the last line. 

Comparing Fig. 3.2 in Getting started with Fig. 4.1, one can notice that the selection of features affects the Fisher 
coefficient. In both examples data were not normalized. The value of F = 40.0 was obtained for 5 features, whereas F
increased to 66.5 when 2 features (teta2 and teta4) were excluded from the data set. Of course it is not true, in general, 
that elimination of some features increases the class separability. Usually, adding features may help discriminate 
different data categories. It is left as an exercise for the reader to show that feature standardization also affects the 

value of Fisher coefficient F.  

 

Fig. 4.1. Report of 'Raw data' analysis for m25.sel (teta2 and teta4 disabled). 

4.4.2. Principal Component Analysis 

Subtracting the pooled mean µµµµ from the features in the training set is the first step in PCA analysis (Krzanowski 1988). 
The data covariance matrix is then estimated and its eigenvalues and eigenvectors computed using Jacobi algorithm 
(Press et al 1988). The eigenvalues [λ

1
, λ

2
, ..., λ

Nx
] are listed in the decreasing order. Their corresponding eigenvectors 

form columns of a projection matrix ΦΦΦΦ whose dimension is Nx×Np. The Np principal components of the data set can be 
obtained by a linear transform 

 

where p
i
=[p

i1
, p

i2
, ..., p

iNp
], i=1,2,...,M. One can show that the covariance matrix of the transformed data is a diagonal 

matrix, diag(λ
1
, λ

2
, ..., λ

Nx
), which means that the principal components are uncorrelated. Typically, only a small 

number Np (smaller than Nx) of principal components is needed to retain all the variance of the original data. These 
correspond to the largest eigenvalues of the covariance matrix. Thus PCA provides a compact, lower dimensionality 
representation of the original feature vectors. To evaluate the usefulness of PCA to data representation, the linear 
dimensionality coefficient d

l
 (Mao and Jain, 1995) is calculated, which is equal to the number of significant eigenvalues 

(more than 97% of the total variance is retained in first d
l
 principal components). Due to the principal components ability 

to optimally represent sets of data, they are called 'most expressive features', MEF (Swets and Weng, 199f).  

PCA analysis example 

A report file generated for m25.sel input after choosing Analysis|PCA menu items is presented in Fig. 4.4.2. The linear 
dimensionality of the m25.sel data is 3. One can notice that for the considered data, Fisher coefficient F=48.7 in the 
principal component space is slightly larger compared to its value in the original data space (F=40.0). However, in 
general, principal components may not be as effective for data discrimination as they are for data representation. 



 

Fig. 4.4.2. Report of 'PCA' analysis for m25.sel (all features enabled). 

4.4.3. Linear Discriminant Analysis 

Let x(k)
i
 denote the ith pattern in class i, i=1,2,...,M

k
, k=1,2,...,Nc. Define the within-class scatter matrix C

W
 as 

 

 

where µµµµ(k) is the mean vector of class k. Similarly, define the between-class scatter matrix CB as 

 

 

where µµµµ is the mean vector of the pooled data. The total scatter matrix is, then 

. 

The goal of linear discriminant analysis is to find a linear transform matrix ΦΦΦΦ such that the ratio of determinants 

 

is maximized (Fukunaga 1991, Mao and Jain 1995). It can be proved that such a transform ΨΨΨΨ is composed of 

eigenvectors corresponding to largest eigenvalues of . Transformation of original data by means of matrix ΨΨΨΨ  

 

produces most discriminating features, MDF, (Swets and Weng 1996), such that MDF
i
 = [MDF

i1
, MDF

i2
, ..., mdf

iNq
] = q

i

= [q
i1
, q

i2
, ..., q

iNq
], i=1,2,...,M, where Nq is usually smaller than Nx.  

To evaluate the usefulness of LDA to classes discrimination, the linear separability coefficient l
s
 (Mao and Jain, 1995) is 



calculated, which is defined as the largest eigenvalue of  (Gallinari et al 1991). As l
s
 changes from 0.0 to 1.0, the 

data set becomes more and more linearly separable. Similarly to PCA analysis, an LDA dimensionality factor is 

calculated, which is equal to the number of largest eigenvalues of  whose sum is greater than 0.97. 

LDA example 

A report file generated for m25.sel input after choosing Analysis|LDA menu items is presented in Fig. 4.2. The linear 
separability of the m25.sel data is 0.98, which means that this set is well separable by hyperplanes in the MDF space. 
One can notice that for the considered data, Fisher coefficient in the MDF space (F=64.3) is larger compared to its values 
in the original (F=40.0) and MEF (F=48.7) data spaces.  

 

Fig. 4.4.3. Report of LDA analysis for m25.sel (all features enabled). 

4.4.4. Nonlinear Discriminant Analysis 

Often, one deals with data sets where clusters of points belonging to different categories can not be separated using 
linear classifiers (i.e. by means of hyperplanes in the feature space). Both PCA and LDA described above use linear 

transformation of the input patterns. These two techniques provide means for feature compression (both MEF and MDF 
type vectors have less elements than the original feature vectors). However, since they are based on linear 
transformations, they can not help in classification of linearly non-separable data. Such data need hypersurfaces instead 
of hyperplanes for clusters separation. Nonlinear classifiers, such as artificial neural networks (Hecht-Nielsen 1989, 
Freeman and Skapura 1991) or k-NN classifiers (Duda and Hart 1973, Fukunaga 1991) may be apropriate to perform the 

classification task.  

Another solution, which is employed in b11 'NDA analysis' is based on finding a nonlinear transformation of the data and 

then applying a linear classifier to the resulting features. In other words, the aim of nonlinear discriminant analysis 
(NDA) is to find a nonlinear transformation of the feature vectors, such that the input patterns are projected on a space 
(possibly of lower dimensionality as in the case of PCA and LDA) in which they become linearly separated (Gallinari et al 
1991, Mao and Jain 1995). This technique is implemented here by using a feeforward artificial neural network (ANN) with 
two hidden layers of sigmoid-type neurons (Fig. 4.4.4).  



 

Fig. 4.4.4 Artificial neural network architecture for nonlinear discriminant analysis. 

Feature vector x is the input to ANN. The number of input terminals is equal to Nx, i.e. to input pattern dimension. The 
output of ANN is a vector y, whose dimension Ny is equal to the number of categories in the data set. Thus the ANN has 

Ny output terminals. There are 3 layers of processing elements (neurons) in the network of Fig. 4.4. Each of them 
implements a simple single-input single-output nonlinear function ξ=f(α), described by 

 

which is sometimes called a logistic function. Its plot has a 'sigmoidal' shape. It is equal to 0.5 for α=0, and smoothly 
changes from 0 to 1 for α varying from large negative values to large positive values.  

The neurons whose outputs are the elements of the y vector, form the output layer of the ANN. Their inputs are linked to 

the outputs g
k
, k=1,2,..,Ng of the so-called second hidden layer. This layer contains Ng neurons. The inputs of the 

neurons in the second hidden layer are driven by output signals h
j
 j=1,2,...,Nh of Nh neurons in the first hidden layer. 

Finally, the first hidden layer is excited by the feature vector x. Each layer of neurons has an extra input, of unit value, 
so-called bias.  

Each connection between layers is allocated a weight coefficient. There are 3 sets of weights in the network of Fig. 4.4 -
{w}, {v}, and {u}. Thus input α to any neuron is a weighted sum of the appropriate bias and output signals from all the 
neurons located in the preceding layer. It follows that the elements of the output vector y are described by 

, 

the outputs of the second hidden layer are given as 

, 

and the outputs of the first hidden layer can be calculated from the formula 

. 

It can be proven (Hecht-Nielsen 1989) that the network of the discussed architecture is able to approximate any smooth 
nonlinear mapping from the input space x to the second hidden layer space g. The output layer performs the function of 
a linear classifier, provided a decision-making block is added. (Vector g belongs to class c

k
 if the output y

k
 is close to 1.0 



and all the remaining outputs are close to 0.0. Decision is inconclusive if more than one output is close to 1.0. Vector g

that causes such situation is allocated to a category c
0
 that is not present in the input data set.) 

The nonlinear transformation considered is performed by the two hidden layers of the network in Fig. 4.4. The input 
patterns x of dimension Nx are transformed into g vectors whose dimension is Ng<Nx. The limited number of g vector 
elements forms a "bottleneck" through which the information passes flowing from input x to output y.  

The neural network has to be trained to be able to perform its function. The training involves adjustment of the ANN 
weight coefficients such that the actual output of thye network y is close to a desired output d. Supervised training 
techniques are used in b11, based on examples of input patterns and correct categories thay belong to, {x

i
, d

i
}, 

i=1,2,...,M. For this purpose, the following error function 

 

is minimized by adjustment of weights u, v, and w. Training the neural network relies in fact on solving a multivariable 
numerical minimization problem. Two training methods are implemented in b11, which are realized sequentially. The 
first is the well-known backpropagation technique (Hecht-Nielsen 1989, Freeman and Skapura 1991). It is done 

iteratively, in a limited number of steps, to provide coarse values of weights. A multivariable optimization routine (Press 
et al. 1996) is then invoked as the second technique, to produce lower values of error and more accurate weights. 

One should note, however, that the minimization problem at hand features multiple minima of the error function. 

Therefore, there is no guarantee that a right solution will be obtained after training, for a given training set. A good 
practice is to repeat the whole process of training few times, each time starting with randomly initialized weight 
coefficients, and selecting the solution which provides the best results.  

Another word of warning relates to the size of the neural network, measured in the number of neurons in hidden layers. 
It is well known that as the ANN size increases, it becomes more accurate, in that the mapping y(x) becomes closer to 
the desired values d, over the set of training examples. At the same time, with the increased number of neurons the 
number of weights increases exponentially. Thus increases the number of unknown degrees of freedom, which are 

adjusted in the process of training. More training examples are needed to provide at least as many input/output data as 
there are unknowns (weights). If this condition is not satisfied, the ANN might memorize the training examples "by 
heart", giving a very low value of error, which could be misleading. Such a network would not possess the required 
ability to generalize. Namely, when presented unseen input patterns, located "in beetween" the training patterns, the 

ANN would produce large errors. This phenomenon is called "overtraining". A good practice is to (1) use as small a 
network as possible, (2) split the available data set into the training set and validation set (or training test set) and 
measure the network performance (in terms of error value) for both sets. If, for given ANN size, the error over the 
training set decreases and th error mesured over the test set starts increasing, the training should be terminated to 
avoid overtraining (Hecht-Nielsen 1989). 

Since the result of ANN training depends on adjustable parameters whose correct (or best) values may be data-
dependent, selection of some parameters is left to the user of b11. These parameters are listed in the 'Neural network 

parameters' box in options window.  

Practice shows that training time is shorter if ANN inputs are standardized. Therefore, the training example patterns are 
standardized for NDA analysis, irrespective of the setting in options window. 

NDA example 1 

A report file generated for m25.sel input after choosing Analysis|NDA menu items is presented in Figs. 4.4.5 and 

4.4.6. After the standard heading (see the analysis reports in Fig.s. 4.4.1, 4.4.2, and 4.4.3), information about the ANN 
size is provided in Fig. 4.4.5 (the number of neurons in the second hidden layer Ng=3 was selected in this example). 
Then, chosen values of backpropagation parameters are displayed and errors obtained in consecutive iterations (in steps 
of 50000 iterations) are listed. After backpropagation, the numerical weight optimization is performed. One can notice 
that for the considered data, Fisher coefficient F=235.9 in the nonlinear components data space is much much bigger 

compared to its value in the original data space (F=40.0). This shows the potential of the NDA technique to separate 
category clusters (Fig. 4.4.7). The report generated after NDA analysis includes also values of weight coefficients (Fig 

4.4.6), as obtained after training. These values can be easily transfered to e.g. Neural Network Toolbox® of Matlab®, for 
further utilization. Figure 4.4.7 presents feature clusters, obtained for m25.sel data file in the 3-dimensional NDA space 
(Ng=3). 



 

Fig. 4.4.5. Report of 'NDA' analysis for m25.sel (all features enabled, Ng=3). 

 

 

Fig. 4.4.6. Neural network weights extracted from the report file of 'NDA' analysis (Ng=3). 

 



 

Fig. 4.4.7. Clusters in NDA feature space for m25.sel data file (Ng=3). 

The Options menu item allows selection of the number Ng of neurons in the second (bottleneck) hidden layer of the 
neural network. The above example showed results that could be obtained for Ng=3. The following example was 

designed to illustrate the other possibility, Ng=2, applied to the same data file.  

NDA example 2 

A report file generated for m25.sel input and Ng=2, after choosing Analysis|NDA menu items, is presented in Figs. 4.8 

and 4.9. The differences between this report and the one shown in Figs. 4.5 and 4.6 relate to the reduced number of 
neurons in the second hidden layer (Ng=2) and, incidentally, different value of iterations in the backpropagation 
algorithm (bpIterLimit=200,000 instead of 500,000). The Fisher coefficient F=2038.1 in the nonlinear components data 
space is much much bigger compared to its value in the original data space (F=40.0). Figure 4.10 presents feature 

clusters, obtained for m25.sel data file in the 2-dimensional NDA space (Ng=2). The clusters belonging to different 
categories can be linearly separated in the NDA space in this case. The straight-line segments drawn in color in Fig. 4.10 
represent the boundaries between a selected category and all the remaining categories. For example, the green line 
separates the points of category #2 from all the other categories (#1, #3, #4, and #5). Areas on the NDA (f1,f2) plane 
that form a common part of sets belonging to two or more different categories (e.g. bottom-right corner on the NDA 

(f1,f2) plane, ie. points where f1 is close to 1 and f2 is close to 0, which apparently would belong to both category #3 
and category #4) represent "inconclusive" cases. Non-existing category #0 is allocated to such points if they occur in 
practice.  

 



 

Fig. 4.4.8. Report of 'NDA' analysis for m25.sel (all features enabled, Ng=2). 

 

 

Fig. 4.4.9. Neural network weights extracted from the report file of 'NDA' analysis (Ng=2). 

 



 

Fig. 4.4.10. Clusters in NDA feature space for m25.sel data file (Ng=2). 

B11 - program for data analysis and classification 

4.5. Classification 

At present, two neural-network classifiers and the k-NN nearest-neighbor classifier (Duda and Hart 1973, Fukunaga 
1991) with k=1 are implemented in b11.  

4.5.1. Nearest Neighbour Classifier 

Let the set SM = {x
1
, x

2
, .., x

M
} be a set of labelled patterns, and let xn ∈ SM be the pattern closest to x. Then the 

nearest neighbor rule for classifying x is to assign it the label (category) associated with xn. The nearest neighbour rule 

is a suboptimal procedure. Its use will usually lead to an error rate greater than the minimum possible, the Bayes rate. 
However, with a very large number of samples (patterns), the error rate is never worse than twice the Bayes rate. On 
the other hand, unlike the Bayessian classifier, the nearest neighbour rule does not require estimation of conditional 
probablility density function for each class, so it is easier to implement.  

k-NN classification example 

Load the supplied f48_10.sel input file, which contains M=96 training patterns, which are the co-occurence matrix-
derived features computed with MaZda for 48 ROIs in two images - 'Foam1' and 'Foam2' (Materka et al. 1999). Since 

each image contains a uniform texture, different in view to the texture in the other image, there are 2 categories defined 
in this example. Run Raw Data analysis, with unchecked feature standardization option. The scatter plot of 3 first 
features you will obtain is illustrated in Fig. 5.1. 



 

Fig. 4.5.1. Scatter plot of patterns made of first 3 features included in f48_10.sel file. 

Close the graphics window and activate k_NN menu item. The report that will be displayed in the output panel of the 
main windows is listed in Fig. 5.2. It indicates that one input pattern is misclassified by the nearest neighbour rule in this 

case. It is sample #61 of category #2, which has been errornously classified as belonging to category #1. Now change 
option settings to enforce data standardization. The k_NN report produced after executing k_NN classification is shown 
in Fig. 5.3. No error is made if data are standardized, in the case of f48_10.sel file. 

 

Fig. 4.5.2. Report file generated for f48_10.sel input (data standardization: OFF). 

 

 

Fig. 4.5.3. Report file generated for f48_10.sel input (data standardization: ON). 



4.5.2. Neural-network 'n-class' classifier 

The 'n-class' classifier employs a feedforward artificial neural network with a single hidden layer of sigmoidal neurons, as 
shown in Fig. 5.4. Feature vector x is the input to the ANN. The number of input terminals is equal to Nx, i.e. to input 
pattern dimension. The output of ANN is a vector y, whose dimension Ny is equal to the number of categories in the data 

set. Thus the ANN has Ny output terminals. 

The neurons whose outputs are the elements of the y vector, form the output layer of the ANN. Their inputs are driven 
by output signals h

j
 j=1,2,...,Nh of Nh neurons in the hidden layer. Finally, the hidden layer is excited by the feature 

vector x. Each layer of neurons has an extra input, of unit value, so-called bias.  

Each connection between layers is allocated a weight coefficient. There are 2 sets of weights in the network of Fig. 5.4 -
{w} and {v}. Thus input to any neuron is a weighted sum of the appropriate bias and output signals from all the 
neurons located in the preceding layer. It follows that the elements of the output vector y are described by 

 

the outputs of the hidden layer are given as 

. 

It can be proven (Hecht-Nielsen 1989) that the network of the discussed architecture is able to approximate any smooth 
nonlinear mapping from the input space x to the output space y. The output layer performs the function of a classifier, 
provided a decision-making block is added. (Vector y belongs to class c

k
 if the output y

k
 is close to 1.0 and all the 

remaining outputs are close to 0.0. Decision is inconclusive if more than one output is close to 1.0. Vector g that causes 
such situation is allocated to a category c

0
 that is not present in the input data set.) 

The neural network has to be trained to be able to perform its function. The training involves adjustment of the ANN 

weight coefficients such that the actual output of the network y is close to a desired output d. Supervised training 
techniques are used in b11, based on examples of input patterns and correct categories thay belong to, {x

i
, d

i
}, 

i=1,2,...,M. For this purpose, the following error function 

 

is minimized by adjustment of weights v and w. Training the neural network relies in fact on solving a multivariable 
numerical minimization problem. Two training methods are implemented in b11, which are realized sequentially. The 
first is the well-known backpropagation technique (Hecht-Nielsen 1989, Freeman and Skapura 1991). It is done 

iteratively, in a limited number of steps, to provide coarse values of weights. A multivariable optimization routine (Press 
et al. 1996) is then invoked as the second technique, to produce lower values of error and more accurate weights. 

 



Fig. 4.5.4. Artificial neural network architecture for 'N
y
-class' data classification. 

One should note, however, that the minimization problem at hand features multiple minima of the error function. 
Therefore, there is no guarantee that a right solution will be obtained after training, for a given training set. A good 
practice is to repeat the whole process of training few times, each time starting with randomly initialized weight 
coefficients (which b11 does, actually), and selecting the solution which provides the best results.  

Another word of warning relates to the size of the neural network, measured in the number of neurons in hidden layers. 
It is well known that as the ANN size increases, it becomes more accurate, in that the mapping y(x) becomes closer to 
the desired values d, over the set of training examples. At the same time, with the increased number of neurons the 

number of weights increases exponentially. Thus increases the number of unknown degrees of freedom, which are 
adjusted in the process of training. More training examples are needed to provide at least as many input/output data as 
there are unknowns (weights). If this condition is not satisfied, the ANN might memorize the training examples "by 
heart", giving a very low value of error, which could be misleading. Such a network would not possess the required 
ability to generalize. Namely, when presented unseen input patterns, located "in beetween" the training patterns, the 

ANN would produce large errors. This phenomenon is called "overtraining". A good practice is to (1) use as small a 
network as possible, (2) split the available data set into the training set and validation set (or training test set) and 
measure the network performance (in terms of error value) for both sets. If, for given ANN size, the error over the 
training set decreases and th error mesured over the test set starts increasing, the training should be terminated to 

avoid overtraining (Hecht-Nielsen 1989). 

Since the result of ANN training depends on adjustable parameters whose correct (or best) values may be data-
dependent, selection of some parameters is left to the user of b11. These parameters are listed in the 'Neural network 

parameters' box in options window.  

Practice shows that training time is shorter if ANN inputs are standardized. Therefore, the training example patterns are 

standardized for NDA analysis, irrespective of the setting in options window. 

Example of 'n-class' classification 

Load the supplied iris.sel input file, which contains the fameous Fisher M=150 training patterns, which are the sepal and 

petal lengths and widths of iris flowers. The dimension of feature vectors is then 4 in this case. There are 3 categories 
(classes) - (1) Iris Setosa, (2) Iris Versicolor, and (3) Iris Virginica. Run Raw Data analysis, with unchecked feature 
standardization option. The scatter plot of 3 first features you will obtain is illustrated in Fig. 5.1. Patterns belonging to 
class '1' are easily separable from other classes; however, separation of vectors belonging to classes 2 and 3 does not 

seam easy. 

 

Fig. 4.5.5. Scatter plot of patterns made of first 3 features included in iris.sel file. 

Close the graphics window. Use the Options menu item to select the ANN parameters as shown in Fig. 4.5.6. Please 
notice, that the number of neurons in the second hidden layer has no effect on the experiment, since the ANN does not 
possess it (Fig. 4.5.4). Its only hidden layer is identified as '1st hidden layer' in the options window (Fig. 4.5.6). There 

are then 2 neurons in the hidden layer in this example, the number of inputs is 4, and the number of outputs is 3. 
Sometimes, such a network is said to have 4-2-3 architecture. 



 

Fig. 4.5.6. Options selected for 'n-class' example with iris.sel file. 

Activate Classification|ANN: n-class (training) menu item. The report that will be displayed in the output panel of 
the main windows is listed in Figs. 5.7 and 5.8. It indicates that one input pattern is misclassified by the the ANN 

classifier in this case. It is sample #134 of category #3, which has been errornously classified as belonging to category 
#2. Now use the k-NN classifier for the iris.sel data, for comparison. Fig 5.9 indicates, that there are 6 mislassification 
errors made by the k-nN classifier with no feature standardization, all misclassifications related to the confusion between 
categoties 2 and 3. One can easily check that the number of classification errors increases to 8 if feature standardization 
options is switched on, in the k-NN classifier case. This example illustrates the capacity of artificial neural networks to 

effectively separate patterns that are otherwise difficult to classify by standard means.  

 

Fig. 4.5.7. Report file generated for iris.sel input and 4-2-3 'n-class' classifier. 

 



 

Fig. 4.5.8. Report file generated for iris.sel input and 4-2-3 'n-class' classifier (continued). 

 

 

Fig. 4.5.9. Report file generated for iris.sel input and k-NN classifier. 

4.5.3. Neural-network 'one-class' classifier 

The 'one-class' ANN classifer, whose architecture is shown in Fig. 5.10, resembles the above-described 'n-class' system. 

The only difference is that the neural network has one output in this case. It this then able to distinguish two categories 
only. These categories are artificially made by allocating any selected category to 'class one' and all the other categories 
from the training set to 'class zero'. The number of category chosen as 'class one' can be entered in the options window 
(Classification - Selected category). In the case of N categories represented in a data set, N different neural networks 
can be trained for data classification, using Classification|ANN: one-class (training) menu item. 



 

Fig. 4.5.10. Artificial neural network architecture for 'one-class' data classification. 

4.5.4. Neural-network classifier testing 

Any trained neural network classifier should be tested on a separate test-data set. This applies to neural networks 
trained as a result of running NDA analysis, as well as n-class and one class classification. The b11 program provides 
tools for such testing, as shown in Fig. 4.5.11.  

 

Fig. 4.5.11. Main menu items showing option for neural-network classifier testing. 

The test-data set for a neural-network classifier should contain image feature vectors that are different from the ones 
contained in the set that has been used for training. Both, training and testing data sets can be prepared in MaZda, in 
the form of *.sel files. 

Prior to calling the testing procedure, one should load the test-data set *.sel file using the Files|Get input data main 
menu item. 

Information about the architecture and weights of the trained neural network classifier (to be tested) are specified in a 
corresponding *.nda or *.cls file. After selecting the testing option shown in Fig. 4.5.11, the appropriate file can be 
loaded into the b11 program. Then testing is performed. 

The report of classifier testing can be saved to disk in a *.tst text-file format, by calling the Files|Save Report menu 
option.  

B11 - program for data analysis and classification 

4.6. Options 

Load the supplied m25.sel input file as described in Getting started help section. Click the Options menu item. The 
options window will appear on the screen (Fig. 4.6.1). Five features (teta1, teta2, teta2, teta4 and sigma) have been 

found in the input file, as indicated in the 'Feature selection box' of the options window. By default, they are all enabled 
for further analysis, which is marked by 'tick' signs placed next to the name of each feature. First 3 enabled features 



from the list are used to graphically present the input data categories in the feature space (Figs. 4.3.4 and 4.3.5 in 

Getting started).  

 

Fig. 4.6.1. Options window after loading m25.sel file. 

Uncheck teta2 and teta4 features in 'Feature selection box' of the options window (Fig. 4.6.2). Now only 3 out of 5 
features are selected for further analysis. 

 

Fig. 4.6.2. Modified options window (two features disabled). 

Close the options window (click on OK button). Select Analysis|Raw data menu item. A graphic window will appear 
showing five data clusters in the [teta1, teta3, sigma] space. Click Flip"teta3" axis menu item to better visualize data 
categories (Fig. 6.3).  



 

Fig. 4.6.3. Clusters of data vectors in (teta1,teta3,sigma) space for m25.sel file 

The 'Feature standardization' option is disabled by default (Fig. 4.6.1); however its is enabled for NDA analysis (Table 
4.6.1). If this option is enabled, mean value is subtracted from each feature and the result is divided by the feature 

standard deviation. The mean value and standard deviation are displayed in the output panel of the main window for an 
analysis procedure executed. 

*) The status can not be changed for this analysis mode.

 

Inside the options window, there is also a group of neural network adjustable parameters, which are related to NDA 

analysis, and neural-network 'one-class' and 'n-class'classification (Fig. 4.6.1).  

Table 4.6.1. Default status of 
'Feature standardization' option

Analysis type Default status

Raw data disabled

PCA disabled

LDA disabled

NDA enabled *)
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5. 3D Data Analysis Module 

3D Data Analysis Module 

5.1. Introduction 

MaZda software, since version 4.00, is capable of 3D data analysis. It loads 3D data form image file series, where each file stores single cross-section of 

3D volume, or from a single file that stores complete 3D information. Such data is usually produced by medical scanners as CT or MRI.  

The 3D Editor of MaZda lets the user define three-dimensional regions of interest (ROI) also called volumes of interest (VOI). The 3D Editor provides 

tools for placing volumes of predefined shape within 3D space of image data, resizing them, stretching along selected direction and rotating. There is also 

a tool implemented for semi-automatic segmentation of 3D image data with elastic surface model.  

MaZda computes a number of textural features within selected 3D regions of interest. The resulting feature lists (or feature vectors, one vector per ROI) 

are presented within the Report window. The feature vectors may be further statistically examined as described in sections 1.5 and 2.5.  

3D Data Analysis Module 

5.2. Switching to the 3D analysis mode 

After MaZda is started it usually shows a window for 2D-image manipulation. To switch to 3D image mode, one has to select View->3D Editor menu 

option or press [Ctrl]+[3] from a keyboard. The 3D Editor window will appear. Through the 3D Editor window the tools for 3D data loading, ROI editing 

and 3D volumes analysis are available. See the following sections for details.  

 

Fig. 5.2.1 Switching to the 3D analysis mode 

3D Data Analysis Module 

5.3. Loading 3D data 

To load 3D image data into the 3D Editor one has to select File->Load image... from 3D Editor menu, press [Ctrl]+[L] from a keyboard or press Load 

image tool button. The Load 3D data dialog window appears to choose input file type and to select file or files to be loaded. If several image files (all the 



files must be stored in a single folder) are to be loaded, one has to select a group of files by a typical Explorer's Shift+Ctrl+Mouse method, and then to 

press Open button.  

 

Fig. 5.3.1. Loading 3D data  

After the data is loaded it is presented within the 3D Editor window in a form of thee perpendicular cross-sections. Quite often the image is being 

presented in wrong proportions. The cause of this appearance is a way the image is produced by a medical scanner. Three-dimensional volume is scanned 

over several parallel cross-sections. The distance between cross-sections is usually higher then distance between adjacent pixels within a cross-section 

image. Or the other way, the depth of a 3D data voxel (the 3D image element) is different from its width or height. To gain appropriate proportions of 

presented image, one needs to adjust these proportions manually by invoking the 3D load options window (File->Image options... from 3D Editor

menu) and setting a voxel proportions appropriately.  

 

Fig. 5.3.2. Setting a voxel proport  

 

Fig. 5.3.3. 3D data before and after setting the right proportions  
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5.4. Adjusting the 3D data view  

The way the 3D data are presented can be adjusted by means of push, pull and turn tools (at the top on the RHS of the 3D Editor window), and with slide 

bars (at the bottom of the 3D Editor window). The view angle can be adjusted after selecting Turn all tool (Fig. 5.4.1). The adjustment of pitch and yaw 

angles is achieved by pressing the left mouse button and sliding the mouse cursor across the 3D Editor window. The roll angle is adjusted by pressing the 

right mouse button and moving the mouse cursor horizontally across the window.  



 

Fig. 5.4.1. Adjusting the view angle  

The viewed data can be zoomed in or out, or rather pulled toward or pushed outward, by means of Push or pull all tool. The user has to select the tool 

and then, while pressing the left mouse button, move the mouse cursor vertically across the 3D Editor window.  

 

Fig. 5.4.2. Zooming the view  

The data is viewed in a form of thee perpendicular cross-sections. Some of these cross-sections may be excluded from viewing by unchecking the X, Y or 

Z check box. The location of cross-section can be adjusted by one of three slide-bars located at the lower part of 3D Editor window.  



 

Fig. 5.4.3. Cross-section adjustment  

The gray-scale window limits on the brightness scale can be adjusted by setting the position of two slide-bars located vertically on the RHS of the window. 

These adjustment tools are useful for correcting the image contrast or overall brightness of presented data. Below the slide-bars there are three radio 

buttons located. Choosing the middle one will cause the image to be displayed in three gray-levels. The slide-bars in this mode serve as gray-level 

threshold selectors. Choosing the lower radio button will cause the data to disappear. The viewed cross-sections are uniformly gray (if no ROI is defined). 

These two modes of image presentation are useful when editing regions of interest with a Flood fill tool (see section 5.5.3).  

3D Data Analysis Module 

5.5. Editing regions of interest 

Basic purpose of MaZda's 3D Editor is to let the user define shapes of regions, within which further analysis is to be performed. Up to 16 regions can be 

defined. These regions may overlap if it is necessary. The region shape is defined with up to a single voxel accuracy.  

5.5.1 Editing regions with predefined blocks 

To start the edition process it is required to select the color (number) of region to be created form the palette below the image presentation area of the 

3D Editor window. By default, the red region (no. 1) is selected. Next the user has to select the "drawing" mode. There are four modes, selectable with 

buttons located at the bottom of toolbox menu on the LHS of the window. In the non-overlapping ROI mode (default) the newly created region will erase 

other regions already created. In this mode every voxel of 3D data belongs to a single region only. In overlapping ROI mode the newly created ROI will 

not erase other regions. Thus, the regions will overlap if created at the same locations, and it is possible that a single voxel will belong to several regions. 

Two other modes are for erasing fragments of already existing regions. In erase active ROI mode, only a region (or its fragment) of selected color will be 

erased. In erase all mode, erasing will affect all the regions.  



 

Fig. 5.5.1. Making a ROI of predefined blocks. Selecting: (1) the region's color, (2) drawing mode and (3) a block to be inserted  

 

Fig. 5.5.2. Adjusting a (4) location, (5) orientation and (6) sizes of a selected block, and (7) accepting the result.  

The simplest way of making a new ROI is to use a predefined blocks. There are four blocks at a choice, sphere, tube, cube and tetrahedron, selectable 

with the toolbox located on the LHS of the 3D Editor window (Fig. 5.5.1). At first a block is located at the center of 3D data space. Its location, 

orientation, sizes, and in some extent shape can be adjusted with tools accessible form the toolbox located on the RHS of 3D Editor window (Fig. 5.5.2). 

While adjustments are being done some parameters regarding location, orientation angles or size are printed on the status bar. After adjustments are 

completed the resulting block can be accepted to augment a ROI of selected color. It can be done by pressing the button with a green checkmark. Clicking 

the button with a red X will cancel the action.  

5.5.2 Switching regions on and off from viewing 

The created regions are visible in a form of color highlights. Sometimes it is handy to temporary hide this highlights. The user can switch the ROI on and 

off from viewing by clicking tiny bars located just below color (ROI number) selection buttons. These tiny bars have also informative function. They are 

colored if the corresponding region exists and grayed otherwise.  



 

Fig. 5.5.3. Viewing ROI  

5.5.3 Flood-filling the volume 

The ROI may be also created by means of flood-filling tool. To get the volume flood-filled, it is convenient to switch the image to three gray-level 

presentation mode (section 5.4) and set up the gray-level scale thresholds to distinguish the considered volume. Next step is to select the Flood-fill tool 

(the button with a jug on it). Now, the user has to point with a mouse cursor at the volume the flood-fill procedure is to fill in. It must bee noticed that 

switching regions off from viewing or the drawing mode will affect the result of flood-filling.  

5.5.4 Defining a ROI with an elastic surface model 

An elastic (or deformable) surface model is a mathematical model of enclosed surface that deforms upon some local characteristics of 3D image. The 

deformation is constrained by tensions modeled within the surface. The final shape of the surface is a compromise, in which these two effects are 

balanced. The final shape of the model strongly depends on initial shape and location of the surface. In MaZda's 3D Editor the model of center point 

deformable surface has been implemented for ROI editing. To start the model, one has to select Create spherical-elastic ROI from the toolbox (Fig. 

5.5.4). The model by default operates in automatic mode. The image influence and tension parameters are set automatically. The user is able to choose 

the initial size and location of the surface with use of move, turn, inflate and deflate tools located on the RHS of the window. In addition the user can 

control the two parameters (Thresh. and Deform.) after switching to one of non-automatic modes of operation. After the satisfactory shape of elastic 

surface has been obtained, the user may approve it by pressing the Accept button (green checkmark).  



 

Fig. 5.5.4. Elastic surface tool for ROI editing: (1) selecting the tool, (2) adjusting the initial size and location of spherical surface, (3) 

adjusting the model parameters and (4) accepting the final shape  

5.5.5 Moving and copying regions 

Any existing region can be moved or copied. To move or copy the region, user has to select the color (number) region to be moved or copied from a 

palette toolbox. Next step is to select the Move or Copy button, both located at the top of the toolbox on the RHS of the window. The three-dimensional 

representation of selected region will appear. The user can change the location of the region by means of move, push or pull tools and a mouse. After the 

new location of the region had been obtained it has to be accepted by pressing the Accept button (green checkmark).  

 

Fig. 5.5.5. Copying the ROI  

Comment. It is possible to change the color of ROI before accepting its new location. In such a case the region will be moved or copied given a new 

selected color.  



5.5.6 Editing individual cross-sections in 2D window 

The region of interest shape can be edited cross-section by cross-section. After switching to the main (2D) window of MaZda program the currently 

selected cross-section perpendicular to a Z direction is automatically uploaded the 2D window (Fig. 5.5.6). The ROI can be edited by means of 2D editing 

tools. After switching back to 3D Editor window the selected cross-section will be updated. On how to use 2D window tools refer to the section 1.3 and 

2.3.  

 

Fig. 5.5.6. 3D Editor window and main MaZda window while editing individual cross-sections  

5.5.7 Undoing and redoing editing steps 

The latest edition steps can be undone by selecting Edit->Undo option from the 3D Editor menu. If the edition step is required, selecting Edit->Redo

option from the menu can restore it.  

5.5.8 Defining a class name of 3D ROI 

The individual ROI can be assigned a class name. The class names of regions are transferred to the report window after computing textural features within 

regions, and then they are used in a further process of data analysis. To assign a class name to a ROI, the user has to right-click on a color palette toolbox 

button. The dialog window will appear for entering the class name. After the ROI is assigned a class name, the class name will be shown while hovering 

with the mouse cursor over the ROI selection buttons of the color palette.  

5.5.9 Saving and loading regions of interest 

The 3D regions of interest can be saved to a file or load from a disk file. The disk files for 3D ROI data storage are given a .voi extension. To save the 3D 

ROI data the user has to select File->Save ROI... option from the 3D Editor menu. To load 3D ROI from a file the user has to select File->Load ROI...

option from the menu.  

3D Data Analysis Module 

5.6. Analysis of 3D data 

MaZda computes a number of textural features within selected 3D regions of interest. To select options of the computation process the user has to select 

Analysis->Options... option from the 3D Editor menu. The analysis options can be then set with the Options dialog window. The image can be analyzed 

as is (Normalization option set to default) or normalized (+/- 3 Sigma or 1%-99% option set) before textural features computation.  

There are two types of 3D image analysis implemented in the current version of MaZda, based on image histogram computation and on co-occurrence 

matrix. These types of analysis may be selected by checking or unchecking the Histogram features and COM features checkboxes. To select the 

number of bits used for image quantization before computing the textural features, one has to click on corresponding radio buttons within the respective 

frame inside the dialog box. Additionally, the COM parameters depend on the distance between pairs of image points that has to be specified to compute 

the co-occurrence matrix. Up to five different values of the distance are supported through the corresponding checkboxes.  



 

Fig. 5.6.1. 3D analysis options window  

Analysis of the 3D data within the defined regions of interest starts after selecting the Analysis->Run 3D analysis... option from the 3D Editor menu. 

The results of the analysis are presented in the Report window. How to further analyze the data is described in sections 1.5 and 2.5  
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